SCLakes.com

SCLakes.com

Bringing fishermen togeather since 1998!
It is currently Fri Dec 15, 2017 10:09 am
Sponsors
       

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Wed Apr 08, 2015 1:19 pm 
Offline
Jedi Master Member
Jedi Master Member
User avatar

Joined: Mon May 21, 2007 5:28 pm
Posts: 283
I have a Elite 7 mounted on the dash of a TR21 and the transducer is mounted under the boat near the water intake for live-wells. It has been there for over a year with no problems now all of a sudden the bracket that slides onto the transducer has broke in half twice the last 2 times I went to the lake. Don't understand why this is happening all of a sudden. Any help would greatly appreciated . Thanks


Top
 Profile  
 
PostPosted: Mon Apr 13, 2015 10:10 pm 
Offline
Jr Member
Jr Member

Joined: Tue Oct 28, 2014 8:16 pm
Posts: 20
Did the transducer get kicked down some how? You haven't hit anything have you? It must be slot on the transducer that the black piece slides into I would think.


Top
 Profile  
 
PostPosted: Wed Apr 22, 2015 9:33 am 
Offline
Senior Member
Senior Member
User avatar

Joined: Tue Jan 30, 2007 4:25 pm
Posts: 146
Location: hendersonville,nc
Im about to buy an Elite 7 this week. Can the transducer with the downscan be easily used on the trolling motor? Is it one trans or must two be used for downscan?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:


All content is copyright © SCLakes.com and its original authors. Forum powered by phpBB.